Author Topic: FoD site issue  (Read 3875 times)

Offline GearHead

  • Initiate of the Inner Dark Path
  • ****
  • Posts: 449
    • View Profile
FoD site issue
« on: April 18, 2012, 07:41:47 PM »
Anyone else experiencing this?

About 9 of 10 times I come to the FoD, I get a completely blank page and have to hit the reload button before I get any content. It's been happening for quite a while, and I get it regardless of my location (I'm in the States), network, browser, or login status.
« Last Edit: April 18, 2012, 07:42:48 PM by GearHead »
"Bernard, float over here so I can punch you."

Offline Guivre

  • Minion
  • *
  • Posts: 54
    • View Profile
Re: FoD site issue
« Reply #1 on: April 18, 2012, 07:46:14 PM »
Yes, here in the UK I get exactly the same thing.

Didn't do it as I came to check the FoD tonight, but you might expect that...

Offline gi6ers

  • Really Like Totally The Most Doomey Thing Ever
  • ***
  • Posts: 8098
  • Clatto Verata N... Necktie
    • View Profile
Re: FoD site issue
« Reply #2 on: April 18, 2012, 07:49:30 PM »
me too.

Offline beefcake

  • Tyrant of the NetherHells
  • ***
  • Posts: 5273
    • View Profile
Re: FoD site issue
« Reply #3 on: April 18, 2012, 08:44:10 PM »
Me also. Maybe a bit more frequently than 9/10 times though. Refresh seems to sort it out though so it's not a major biggy.

Offline Overrevdsquat

  • Chosen Heretic
  • ***
  • Posts: 327
    • View Profile
Re: FoD site issue
« Reply #4 on: April 18, 2012, 09:36:07 PM »
and me.

Offline caerban

  • Dark Overlord of Hell
  • *****
  • Posts: 2152
  • The Dark Side of the Moomin
    • View Profile
Re: FoD site issue
« Reply #5 on: April 18, 2012, 10:22:46 PM »
And I.
"No matter how tempted I am with the prospect of unlimited power, I will not consume any energy field bigger than my head."

Offline leadhead

  • Thread Killer
  • Dark Overlord of Hell
  • *****
  • Posts: 2300
    • View Profile
Re: FoD site issue
« Reply #6 on: April 18, 2012, 10:39:10 PM »
It does it for me every time.  It has been that way since the time when I was locked out and was unable to access the FOD from home for months.  I've gotten used to it now, I just hit refresh without thinking about it.
Cult of Inevitable Decay painted:  93/123 (Heresy), 22/22 (non Heresy)

What was that universal greeting?  "Bah weep, grah nah weep, ninny bong!"  Hot Rod, Transformers: The Movie

I have a tweeter thing now.  I might even use it.  @leadpaintshed if I can figure out how to

Offline The Commissar

  • Initiate of the Inner Dark Path
  • ****
  • Posts: 367
    • View Profile
Re: FoD site issue
« Reply #7 on: April 18, 2012, 10:41:20 PM »
Same here
“Beer is proof that God loves us and wants us to be happy.”
Benjamin Franklin

Offline DRAGON

  • LORD OF WHITE METAL MOUNTAIN
  • Supreme Archfiend of Hell
  • ***
  • Posts: 6257
    • View Profile
Re: FoD site issue
« Reply #8 on: April 19, 2012, 07:20:41 AM »
Same here - seem to remember Andy said it was something to do with the shared server  :shrug:
Heaven doesn't want me. Hell is afraid i will take over !
OFFICIAL WINNER UDOD 2012
Minis painted this year (2013) : Too few !
Heresy Dragon - paint in progress - coming soon... seriously !

http://foddragon.mybrute.com

Offline ballistic_bro

  • Dark Lord
  • *
  • Posts: 1096
  • Do I need to say it?
    • View Profile
Re: FoD site issue
« Reply #9 on: April 19, 2012, 07:32:53 AM »
Same here, using ie8 or 9 or iPhone, doesnt appear to be browser specific.
There's one thing you never put in a trap, if you're smart.
If you have any plans about seeing tomorrow,
there's one thing you never ever put in a trap,
me...........

Dr Who (2010)

Offline Apologist

  • Minion
  • *
  • Posts: 54
    • View Profile
Re: FoD site issue
« Reply #10 on: April 19, 2012, 09:33:59 AM »
 :metoo:
Chrome has the same issue. As Dragon notes,
Quote
seem to remember Andy said it was something to do with the shared server
. Presumably not something that can be easily fixed. :doh:

Offline Bergil

  • Initiate of the Inner Dark Path
  • ****
  • Posts: 353
    • View Profile
Re: FoD site issue
« Reply #11 on: April 19, 2012, 11:03:06 AM »
Yup

Offline Gangrel

  • Scientist Supreme
  • Dark Warlord
  • **
  • Posts: 1456
    • View Profile
Re: FoD site issue
« Reply #12 on: April 19, 2012, 12:53:12 PM »
Yep. From personal experience it happens with Windows, Android and Mac! As Leadhead said, I just refresh without thinking now.
"That's interesting. Horses don't USUALLY explode, no matter how hard you hit them."

Hellboy - "Wake the Devil", Mike Mignola

Offline Inappropriate Socks

  • Badass hosiery
  • Lurker
  • Posts: 9
    • View Profile
Re: FoD site issue
« Reply #13 on: April 19, 2012, 04:04:54 PM »
Thought it was just me.
OH I have lots of socks, I hide them in a box, People try to steal them all but can't defeat the locks HEY!

Offline ink the troll

  • Dark Underlord
  • ****
  • Posts: 1887
  • short, fat & ugly
    • View Profile
Re: FoD site issue
« Reply #14 on: April 19, 2012, 05:00:09 PM »
Been like that since quite a while. Not just on first access but usually for every topic.
sanity is for cowards
Blogthing

Offline MartinWhitmore

  • Dark Apprentice
  • ******
  • Posts: 901
    • View Profile
    • The Art & Blog of Martin Whitmore
Re: FoD site issue
« Reply #15 on: April 19, 2012, 05:23:58 PM »
Huh. I figured it was just something weird on my end. Well, I'm certainly willing to put in the extra click - but I'd be concerned that new visitors would think the site was broken/didn't exist.



perceptionistruth

  • Guest
Re: FoD site issue
« Reply #16 on: April 19, 2012, 07:01:07 PM »
Not sure why being on a shared server would cause the issue, but it happens here too.

These are the headers when it works,

HTTP request sent, awaiting response...
  HTTP/1.1 200 OK
  Date: Thu, 19 Apr 2012 17:58:11 GMT
  Server: Apache
  X-Powered-By: PHP/5.3.10
  Pragma: no-cache
  Cache-Control: private
  Expires: Mon, 26 Jul 1997 05:00:00 GMT
  Set-Cookie: PHPSESSID=5bc73bbc1e0bed815b670b4eb5cc3e76; path=/; domain=.forum-of-doom.com
  Last-Modified: Thu, 19 Apr 2012 17:58:12 GMT
  Keep-Alive: timeout=1, max=100
  Connection: Keep-Alive
  Transfer-Encoding: chunked
  Content-Type: text/html; charset=ISO-8859-1
Length: unspecified [text/html]

These are the headers when it fails,

HTTP request sent, awaiting response...
  HTTP/1.1 200 OK
  Date: Thu, 19 Apr 2012 17:58:11 GMT
  Server: Apache
  X-Powered-By: PHP/5.3.10
  Expires: Thu, 19 Nov 1981 08:52:00 GMT
  Pragma: no-cache
  Cache-Control: private
  Set-Cookie: PHPSESSID=3aaa54f84421be5bea54c2d8b995ef7a; path=/; domain=.forum-of-doom.com
  Content-Length: 0
  Keep-Alive: timeout=1, max=100
  Connection: Keep-Alive
  Content-Type: text/html
Length: 0 [text/html]

When it fails, the server is returning a content length of 0 even though it returns a 200 status code.  It's most likely a fault with the configuration of the web servers or caching.

If I had to guess, I'd say where-ever the site is hosted has a number of servers, behind a reverse proxy, and one or more of those servers is wrongly configured or has a corrupt copy of the site.
« Last Edit: April 19, 2012, 07:02:07 PM by perceptionistruth »

Offline Balgin Stondraeg

  • Supreme Archfiend of Hell
  • ***
  • Posts: 6531
    • View Profile
Re: FoD site issue
« Reply #17 on: April 19, 2012, 07:18:33 PM »
Anyone else experiencing this?

About 9 of 10 times I come to the FoD, I get a completely blank page and have to hit the reload button before I get any content. It's been happening for quite a while, and I get it regardless of my location (I'm in the States), network, browser, or login status.

Yes. I've been experiencing this for months now. Usualy refreshing fixes it. And it's not as common as it once was but still highly infuriating.
Balgin Stondraeg, proud member of Clan Stondraeg, son of Guthram, husband of Urwena, brother to Hengrek, Murnak and Dradan. Father of Cigfa. Miserable old fool to disrespectful friends.

perceptionistruth

  • Guest
Re: FoD site issue
« Reply #18 on: April 19, 2012, 10:07:20 PM »
It's definitely a configuration problem with the hosting provider's web servers (UKHost4u).

It's not *too* bad for real browsers, refreshing once for me seems to make everything work afterwards, maybe that's due to keep-alives or sessions.  However, if you make brand new connections, the failure rate is a bit depressing.  Using wget to load the index page 20 times, gives me 15 failures and 5 successes.

Offline Wanderer

  • Heretic
  • **
  • Posts: 178
    • View Profile
Re: FoD site issue
« Reply #19 on: April 19, 2012, 11:43:29 PM »
Yep, I get it too! I have to refresh before it will load the forum
http://plagueofones.mybrute.com

Hammer'N'Ales Wargames Club, Hucknall, Nottingham. Tuesdays and Sundays for fantasy, sci-fi and historical gaming. See here for details. (external link to UKCord wargaming & modelling forum)

Offline Big Boris

  • aka Andy Foster, Heresy Miniatures Owner/Prisoner
  • Administrator
  • Tyrant of the NetherHells
  • *****
  • Posts: 5996
  • Dragon Slayer. At last.
    • View Profile
    • http://www.heresyminiatures.com
Re: FoD site issue
« Reply #20 on: April 22, 2012, 12:53:47 PM »
If everyone wants to chip in, we can move it to a private server.

Offline Big Boris

  • aka Andy Foster, Heresy Miniatures Owner/Prisoner
  • Administrator
  • Tyrant of the NetherHells
  • *****
  • Posts: 5996
  • Dragon Slayer. At last.
    • View Profile
    • http://www.heresyminiatures.com
Re: FoD site issue
« Reply #21 on: April 22, 2012, 12:54:05 PM »
ie some other hosting company...

perceptionistruth

  • Guest
Re: FoD site issue
« Reply #22 on: April 23, 2012, 12:13:41 AM »
ie some other hosting company...

It's not because it's on shared hosting, it's an actual misconfiguration at the hosting provider's end.  Which still doesn't help, but just wanted to say it in case your hosting company is fobbing you off.